「Pixabay images」でエラーが出る!WordPressのプラグインで出来る解決方法!

MANAVIVA講師橋本知憲
橋本知憲
こんにちは。今回はPixabay imagesのエラーの解決方法についてご紹介していきます。

Pixabay images について

まずはPixabay imagesについて簡単に説明していきます。

フリー素材を検索して投稿に埋め込める

Pixabayというフリー素材サイトがあるのですが、そこの画像をWordPress内で検索して埋め込めるというめちゃくちゃ便利なプラグインです。ブログをやっている人だとわかると思いますが、画像の埋め込みってめちゃくちゃ面倒なんですよね。特にフリー素材サイトから画像をとってくるときなんか「Googleで画像を探す」→「ダウンロードする」→「WordPressにアップロード」→「埋め込み」といったステップを踏まないといけないのでかなり面倒くさいですし、ダウンロードした画像を削除しないとフォルダが散らかってしまいます。

それをWordPress内で簡単に出来るプラグインがPixabay imagesなのでとても便利なことが分かると思います。

 

 

 

Pixabay images
こんな風にWordPress内で検索できる

謎のエラー「Error: File attachment metadata error」

ところが2019年の11月ごろからだと思いますが、このプラグインが突然使えなくなってしまったんです。このような画面が出てくるんです。

WordPressのエラー

Error: File attachment metadata errorって書いてあります。うーん困った。

これでは便利なPixabay imagesが使えなくなってしまいます。

原因はWordPress5.3との相性

色々試行錯誤しましたが、原因はPixabay imagesとWordPress 5.3との相性に問題があるようです。まずは、そのうちPixabay imagesの方がWordPress 5.3に対応してくれると願いましょう。そのうえで今どうしてもPixabay imagesが使いたい場合の応急処置の方法を紹介します。

WordPress5.2にダウングレードする

WordPress5.3で相性が合わないのであればWordPress5.2にダウングレードしちゃいましょうって話です。ダウングレードって聞くと難しいと思うかもしれませんが、プラグイン一つで出来ちゃうので誰でも簡単にできます。

まずは、「WP Downgrade | Specific Core Version」というプラグインを検索してWordPressに追加してください。「WP Downgrade」とWordPress内で検索すれば出てきます。

WP Downgrade

そして、インストールして有効化します。

 

そして「設定」→「WP Downgrade」からプラグインを開きます。

バージョン選択

すると、画像のようにダウングレードしたいバージョンを聞かれるので「5.2.4」と入力してください。そして「変更を保存」を押します。

すると、下に「Up-/Downgrade Core」と出てくるのでクリックしてください。

 

このような画面が出てくるので「再インストール」をクリックしてください。

しばらくするとダウングレードが完了します。

ダウングレード完了

この画面が出ればOKです。

ダウングレード後について

ダウングレードすると、今まで通りPixabay imagesプラグインが使えるようになっていると思います。

 

解決

ちゃんとエラーが出ずにダウンロードできました!

 

最新情報をチェックしよう!